在Ubuntu系列系统上安装网易云音乐

POST-[541] POST

时间:2017-01-08 13:51:29

作者:sleepycow

评论:0 条

分类:Linux / OS EXP

在感叹Linux平台下没有好的在线音乐客户端,网易业界良心啊,一款网易云音乐,跨平台,兼容在世所有平台哈哈哈。

先去网易云音乐主页下载linux下安装包,我用的是linux mint 18.1 基于Ubuntu一脉,不用多想,下载ubuntu 64bit版本的,下载来是DEB包

双击直接安装,却告诉我依赖未满足……作孽哎

11

 

换个偷懒思路,转到终端下面,手动安装命令

sudo dpkg -i netease-cloud-music_1.0.0_amd64_ubuntu16.04.deb

同样提示安装失败,但是却已经表明失败原因(手动安装的好处,告诉你缺少哪些必要依赖)

正在选中未选择的软件包 netease-cloud-music。
(正在读取数据库 ... 系统当前共安装有 219419 个文件和目录。)
正准备解包 netease-cloud-music_1.0.0_amd64_ubuntu16.04.deb ...
正在解包 netease-cloud-music (1.0.0) ...
dpkg: 依赖关系问题使得 netease-cloud-music 的配置工作不能继续:
netease-cloud-music 依赖于 libqt5multimedia5 (>= 5.0.2);然而:
未安装软件包 libqt5multimedia5。
netease-cloud-music 依赖于 libqt5multimedia5-plugins;然而:
未安装软件包 libqt5multimedia5-plugins。
netease-cloud-music 依赖于 libqt5multimediawidgets5;然而:
未安装软件包 libqt5multimediawidgets5。
netease-cloud-music 依赖于 libqt5libqgtk2;然而:
未安装软件包 libqt5libqgtk2。

dpkg: 处理软件包 netease-cloud-music (--install)时出错:
依赖关系问题 - 仍未被配置
正在处理用于 hicolor-icon-theme (0.15-0ubuntu1) 的触发器 ...
正在处理用于 desktop-file-utils (0.22-1ubuntu5) 的触发器 ...
正在处理用于 mime-support (3.59ubuntu1) 的触发器 ...
在处理时有错误发生:
netease-cloud-music

找到原因所在,用命令行解决(此命令为强制更新之前提醒缺省的组件)

sudo apt-get -f install

在次运行dpkg安装命令,顺利过关!见效果图

2017-01-08-13-36-36-%e5%88%9b%e5%bb%ba%e7%9a%84%e6%88%aa%e5%9b%be